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1. Introduction

NoteZ is a program | wrote to help me organise my life. At first | only used it myself, but
then friends began to take copies, and their suggestions have helped smooth the rough
edges and develop it to the point where | now find it an essential part of my work. This
version, NoteZ 3.22, is definitely the best yet, and it is available both for Windows 95 and
for Windows NT on Intel. It would also be available for NT on MIPS and Alphas if | had a
suitable machine to compile it on (any offers gratefully received).

Whats new?

Installing NoteZ

Notes

Times/Dates and Alarms

Storing Data
NoteZ Windows

Using This File




Whats new?

Version 3.22 is a relatively minor upgrade over the previous version 3.21, and the changes
are to take advantage of the new features in Windows NT 3.51 and Windows 95. The only
change of any consequence is that notes now contain rich text and can be formatted like a
mini word processor. Notes also now have a right click menu.

In all previous versions of NoteZ the notes became read-only as soon as you switched away
from them, and you had to double-click on the note to edit the text. So many people have
complained about this that Ive removed this feature. If you accidently overwrite a note
because it pops up while you were typing in another application then just select Cancel
changes from the right-click menu.

Version 3.22 is 32 bit only and will not run on Windows for Workgroups or earlier versions of
Windows.



1.1 Installing NoteZ

If you are upgrading a previous installation of NoteZ then just unzip ntz322.zip into a
convenient temporary directory to produce the files readme.wri, unzip.bat and notez.zip,
then unzip notez.zip. Now just copy the new notez.exe over your existing notez.exe and
that is all you need to do. When you run the upgraded NoteZ it will pick up all the old
data. Dont use the method below or you will risk losing your current notes. Always
backup any important data before upgrading.

NoteZ does not have an install program, you install it by unzipping the file ntz322.zip. You
will need version 2 of pkunzip or later. Unzipping will produce the files readme.wri,
unzip.bat and notez.zip. Typing unzip will run the batch file to decompress the NotezZ
program files, and it will also produce two directories containing example NoteZ folders.
You can unzip notez.zip yourself, but note that you must use the -d qualifier to correctly
produce the sub-directories.

NB NoteZ is fussy about the location of the subdirectories containing folder data. Well
actually it doesn't matter where the sub-directories are as long as NoteZ knows where they
are. The easiest way to avoid hassle is to move the ntz322.zip file to the directory where
you want NoteZ installed, unzip it there, and then don't move the file notez.exe or any of
the NoteZ sub-directories. If you later want to move things around see the section on
moving folders.




1.2 Note Windows

The basic element of NoteZ is the note. This is a direct rip-off of the 3M Post-It concept,
and by default notes even share the same yellow colour as Post-Its. You can create notes,

type some text into them and then leave them lying around on your Windows desktop just
as you would with Post-Its.

Unlike Post-Its NoteZ notes can have alarms, so if the note is for an appointment you can
have your favourite .wav file sound when the appointment is due.

Each note can store a large amount of text, so you can use them for substantial

documents. Folders of notes can be searched by note title or note contents, so notes can
be used as a simple database system.



1.3 Times/Dates and Alarms

Where NoteZ scores over Post-Its is that you can attach a time and date to a note, and the
note then behaves like an entry in a diary. Unlike a diary you can make an alarm sound
when the note is due, and you can set a warning, for example to have the alarm go 15
minutes before the appointment time. You can make notes repeat, for example every
week, for regular appointments.



1.4 Storing Data with NoteZ

You can also use notes as a scrapbook by typing useful bits of information into them.
Notes can be organised into folders, so you might keep telephone numbers in one folder
and your favourite recipes in another. Each note can hold a large amount of text, so a lot
of data can be stored. To find a telephone number or recipe or whatever you can search
the note titles or the note text or both.



1.5 NoteZ Windows

There are three windows you can use to handle notes. The Main window shows you the
current folder, the current time and a list of all the notes in the current folder. This has a
menu bar you can use to create notes, delete notes, change the note appearance and so
on. It also has the obligatory button bar. NoteZ also has a Diary window which shows you
seven days at a glance, and it has a Calendar window which marks with a red dot days
which have a note set. These two windows can also be used to create and delete notes.




Using the Keyboard

NoteZ does not make extensive use of the keyboard, but does use the following keys:

Ctrl+PageDown, Ctrl+Tab, Ctrl+F6 - These all jump between the windows NoteZ displays.
Pressing these keys repeatedly will cycle around the main NoteZ window, the Diary
and Calendar, if they are visible, and any visible notes.

Ctrl+PageUp, CtrI+Shift+Tab, Ctrl+Shift+F6 - As above, but these keys move between
windows in the reverse order to the keys above.

In Note windows the following keys are used:
Ctrl-S - Save changes to the note text
Escape - Abandon changes to the note text
Ctrl-B - Make text bold

Ctrl-1 - Make text italic

Ctrl-F - Change the text font



1.6 Using This Help File

| have laid out the help file as if it is @ manual, so you can read it thoroughly by going
through page by page, or if you are just browsing then you can use the hyperlink structure
to wander through it. If you are looking for a specific piece of information the quickest way
to find it is probably using the Search button. | have tried to provide a comprehensive list

of keywords.



2. The NoteZ Main Window
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The main window is the central control point for NoteZ, but most simple things like creating
and displaying notes can be done from the other windows or when the main window is
iconised. Itis normally only necessary to use the main window for things like searching
notes, creating new folders or customising NoteZ, for example by changing fonts.

Creating Notes

Editting Notes

Copying and Pasting Notes
Moving Notes between folders

Deleting Notes
Displaying and Hiding Notes

Printing Notes
Selecting Notes byTime

Selecting Notes by Contents
Changing the Current Folder
Changing the Alarm
Changing Note Colours
Changing Fonts

Sorting Notes
Displaying the Diary and Calendar

The Button Bar
The Note List




2.1 Creating Notes

There are four ways to create a new note from the Main window.

1.

Choose the Create note command from the Note menu. This will display the Edit
note dialog and you can choose the note title, alarm, size and if you wish import a
file.

Click the Create note button on the Button Bar. This will display the Edit note dialog
and you can choose the note title, alarm, size and if you wish import a file.

Drag a file from File Manager and drop it on the note. This will create a new note
containing the file and using the default note size. The file name will be used as the
note title. You can edit the note to change the title and size.

Paste a note that has previously been copied.



2.2 Editting Notes

To edit a note from the Main window click on the note title in the Note List to select it and
then choose the Edit note command from the Edit menu. If more than one note is selected
then only the first in the list will be editted. This command is disabled if there are no notes

selected in the Note List.

You can also edit notes from the note windows.



2.3 Copying and Pasting Notes

Copying and pasting notes is used for moving whole notes between folders; to copy and
paste note text simply display the note and then perform the clipboard operation from the
note window.

To cut, copy or paste a note or notes from the Main window click on the note title(s) in the
Note List to select it and then choose the Cut note, Copy note or Paste note command from
the Edit menu. This command is disabled if there are no notes selected in the Note List.



2.4 Deleting Notes

To delete a note or notes from the Main window click on the note title in the Note List to
select it and then choose the Delete note command from the Note menu. If more than one
note is selected then all the selected notes will be deleted. This command is disabled if

there are no notes selected.

You can also delete notes from the note windows.




2.5 Displaying and Hiding Notes

To quickly display a single note from the Main window double left-click on its title in the
Note List. Alternatively, click on the note title in the Note List to select it and then choose
the Show note command from the Note menu. If more than one note is selected then all
the selected notes will be displayed. This command is disabled if there are no notes
selected.

To hide a note from the Main window click on the note title in the Note List to select it and
then choose the Hide note command from the Note menu. If more than one note is
selected then all the selected notes will be hidden. This command is disabled if there are
no notes selected.

There are Show and Hide buttons on the Button Bar to act as shortcuts for the menu
commands.

You can also display notes from the Diary and Calendar windows, and hide them from note
windows.



2.6 Printing Notes

To print a note or notes from the Main window click on the note title in the Note List to
select it and then choose the Print note command from the Note menu. If more than one
note is selected then all the selected notes will be printed. This command is disabled if
there are no notes selected.

There is a Print button on the Button Bar to act as shortcut for the Print note menu
command.

You can print the list of note titles by selecting the Print list command from the Note menu.

You can also print notes from the note windows.



2.7 Selecting Notes by Time

You can sort the notes in the Note List by time, and this may be sufficient to give you an
idea of when notes are scheduled. If you need more information there are two commands

on the Select menu you can use.

The Overdue notes command on the Select menu selects all notes whose alarm time is
earlier than the current time. There is an Overdue notes button on the Button Bar to act

as a shortcut for this command.

To select all the notes whose alarms are due within a given period use the Due by.. notes
command from the Select menu to display the View Notes Due Within dialog box.

View Motes Due Within
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If you enter the time within which you want to select notes and click OK then all the notes
due within the time will be selected. You can then display them with the Show note
command from the Note menu, or by clicking the Show note button from the Button Bar.



2.8 Selecting Notes by Contents

You can search through the notes in folder to look for some text. To do this choose the
Search notes command from the Select menu. This will display the Search Notes dialog
box.
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In this box you enter the text you want to search for, and you can make the search sensitive
or insensitive to case. When you click OK NoteZ will search the notes and then it will select
the notes that contain the text in the Note List, but it will not immediately display them. To
display the found notes use the Show note command from the Note menu or click the Show
note button on the Button Bar.

The reason for doing the search this way is that suppose the first search finds too many
notes, and you want to narrow them down. If you leave the notes selected from the first
search and then search again, you can check the Search selected notes radio button to
specify that only the notes selected will be searched this time. This allows you to do
repeated searching on a subset of the notes until you find the one you want. If you want to
search all the notes again then just click the Search all notes radio button.



2.9 Changing the Current Folder

At the top left of the Main window is a drop down list containing the names of the NoteZ
folders. You can change to a different folder simply by choosing the folder name from this
list. Alternatively you can change folder by selecting the Change folder command from the
Select menu. This will display the Change Folder dialog box.

Choose Folder

Path to NoteZ folders
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Select folder
[diary] Hew

[recipes]

At the top of the dialog box is an edit control showing the directory where the folders are
kept. This is normally the same as the directory where you installed NoteZ. For example,
suppose you installed NoteZ in a directory called c:\notez. The installation process will have
created two subdirectories, diary and recipes, containing the two example folders. The edit
control shows c:\notez and the list of folders shows diary and recipes.

To change folder just click on the folder name in the Select folder list to highlight it and click
OK. As is usual in Windows double clicking on the folder name jumps straight to that folder
without you having to click the OK button.

You can use this dialog to create a new folder simply by clicking the New button. You will
be asked for the folder name and you can type the new name and click OK, or click Cancel
to abort. The folder name must follow the same rules as a filename. Normally this means
it must be eight characters or less and must not contain any spaces or special characters,
but if you are using NTFS on Windows NT you have more freedom with filenames.

Finally, there are times when you might want to change the Path to NoteZ folders field.

You might want to keep two entirely different sets of folders in two different directories, and
if so you will need to change the field to change to the other set of folders. Alternatively
you might have moved the folders so that they are no longer in c:\notez. For example
suppose you moved them to a directory called c:\windows\notez, in that case you need to
enter c:\windows\notez in the Path to NoteZ folders field.




2.10 Changing the Alarm Sound

To change the alarm used in NoteZ use the Change Alarm command from the Select menu
in the Main window. Any Windows .wav format file can be used as an alarm.



2.11 Changing Note Colours

You use the Change colours command from the Select menu to change the default note
colours for the currently open folder. You can also choose to change all existing notes to
the new colours by checking the Change all existing notes box.

This is a different effect to changing the note colour from a note system menu. When you
change colour from a note you are changing just that notes colours. When you change
colour from the Main window you are changing the default colours that will be used for any
new notes.

Colours are stored on a folder by folder basis, so you can use different colours for different
folders.



2.12 Changing Fonts

You can change the fonts that NoteZ uses for the Main window, the notes, and the Diary
using the Change font command from the Select menu. This has a sub-menu with
commands to change the note, Main and Diary font. Any font can be used, and the chosen
font will also be used when printing.

Note that the font is stored on a folder by folder basis, so different fonts can be used for
different folders. Note also that changing the note font affects all notes, you cannot
change the font in just one note in a folder.



2.13 Sorting Notes

The note titles in the Note List can be sorted either alphabetically or chronologically. To
sort them alphabetically choose the Sort by title command from the View menu or click the
Sort by title button on the Button Bar. To sort them chronologically choose the Sort by
time command from the View menu or click the Sort by time button on the Button Bar.

The sort type is remembered on a folder by folder basis. For example, you would probably
want to sort a telephone list folder alphabetically and a diary folder chronologically.



2.14 Displaying the Diary and Calendar

If the Diary or Calendar are hidden, or if they just happen to be obscured by other windows
then you can display them from the Main window by choosing the Show Diary and Show
Calendar commands respectively from the View menu.



2.15 The Button Bar
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The Button Bar provides a shortcut to the most common menu commands.

On the far left is a drop down list showing the current folder. You can change folder simply
by selecting a folder name from this list.

Next along is a static display that shows the current time.

To the right of the time are a series of buttons. From left to right these buttons are:

Create a new notes

Display a note or notes

Hide a note or notes

Print a note or notes

Select all overdue notes

Search notes for text

Sort notes alphabetically by title
Sort notes chronologically by alarm

In this release of NoteZ the button bar is not customisable.



2.16 The Note List

The note list displays the alarms and titles of the notes in the current folder. These can be
sorted either alphabetically by title or chronologically by alarm. For many of the Main
window menu commands you have to select the notes you want the command to apply to.

For example to print some notes click on the titles you want to select them and then
choose Print note from the Note menu.

Double clicking on a note title is a quick way to display that note.



3. Note Windows
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The note is the basic object that NoteZ handles. A note has a title, some text and optionally
a time/date and an alarm. This section describes how to these parts of a note can be used.

The Right-click Menu

The Note Title

The Note Text

The Alarm button

The Note Size and Border
The Note Font

Printing Notes
Saving data from Notes

Moving Notes between Folders
Editting the Note Style

Changing the Note Colour
Deleting Notes

Hiding Notes




3.1 The Right-click Menu

Cut
Save changes Copy
Save as Paste
P['_"t_ Copy note
Edit title Cut note
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Mote colour

Cancel changes
Delete

Hide Note
Cut, copy and paste text

Copy note
Cut note

Save changes
Save as

Print Note

Edit the note title
Hide note

Note colour

Cancel changes
Delete Note




3.2 The Note Title

The title is the basic label for a note. The title appears in the note list in the main window,
and also in the Diary, so it is normally a brief summary of the note contents. Using the
main window you can sort notes by their titles, and you can search the titles for text.

The title is set when the note is first created, or you can change the title either by selecting
the Edit command from the right-click menu or by double left-clicking the title bar. Both of
these bring up the Edit Note dialog. This also allows you to change the note style and

make it always on top.



3.3 The Note Text

Notes can hold a very large amount of text, limited only by the available memory. The text
in notes can be formatted to change the font and colour just like a mini word processor.

Use the right-click menu or the shortcut keys control-B and control-I for bold and italic and
control-F to change the font.

When you change the text in a note the note title will change to indicate that the contents
are unsaved. At any time you can select Save changes from the right-click menu or the
shortcut key control-S to save the changes. The changes are saved automatically when
the note is hidden or when NoteZ exits so you wont lose any work even if you forget to
save the changes.



3.4 The Alarm Button

The alarm button shows the note time/date and whether the alarm is on or off. To change
the note time click the alarm button and the Edit Note Time dialog will be displayed.

Edit Note Time
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In this dialog box you enter the date and time you want the alarm set to. If you leave the
Alarm On box unchecked then the alarm will be attached to the note, but it will not be
active. If you want the alarm to be active then check the box. If the alarm is active then
the current alarm file will be played when the PC time matches the note time. If the alarm
is active and the alarm time is older than the PC time then the note will automatically be
displayed when NoteZ is started.

It can be useful to have an alarm set but not active because you can use the alarm time to
sort notes into chronological order. Having the alarm off means you don't get all the
outdated notes springing up each time you run NoteZ.

There is more to setting alarms than just a simple time. For example if you have an

appointment at 10.00am you probably want a few minutes warning to get ready. If you
click the Warning button then the Give Warning of Alarm dialog appears.
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With this box you can choose what warning you want. If you enter a warning period and
check the Set as default box before clicking OK then the value you enter will be remembered
and restored the next time the Warning dialog box is opened. If you tend to use the same
warning period for all notes this saves retyping the warning each time.



As well as having a warning on a note alarm you can specify a duration. For example if you
are away on holiday for a week you can specify a duration of 7 days. This means that in the
Calendar the next 7 days from the start of the note will be marked red.

You can also make an alarm repeat by clicking the Repeat button. For example to avoid
forgetting your wedding anniversary you can make a note repeat every year. A more
prosaic use might be to make a note repeat every 7 days for a regular weekly appointment.
You can choose how many repeats you want; leaving the number of repeats set to 0
means repeat indefinitely.

Finally, if you want to postpone an alarm you can click the Defer button and choose how
long you want to postpone it for.



3.5 The Note Size and Border

There are four sizes of note, small, medium, large and sizeable. The first three of these
are fixed sizes and are set when the note is created, although you can change the size by
editting the note. Sizeable notes are initially the same size as a medium note, but you can
resize them simply by dragging the border of the note.

Resizeable notes are more flexible, but | think they look ugly compared to the fixed size
notes. However both are provided, so just choose whatever suits your own taste. When
you choose a size in the Edit Note dialog you can check the Set as default box to make your
choice the default for all future notes in the folder.

You can change the fixed sizes by making the entries listed below in notez30.ini in the
[NoteZ] section. The sizes are in eighths of an inch; on a usual display one eighth of an
inch is 12 pixels. The numbers below show the default values.

[NoteZ]
SmallWidth = 12
SmallDepth = 12
MediumWidth = 16

MediumDepth
LargeWidth = 32

LargeDepth = 20
ResizeWidth = 16
ResizeDepth = 16

16



3.6 The Note Font

By default notes will use the smallest size of the MS Sans Serif font. You can change the
default font by choosing the Change font/Note font from the Select menu in the Main
window.

You can also format the text within notes to different fonts by selecting the text and
choosing Font from the right-click menu, or using the shortcut keys control-B and control-I
for bold and italic and control-F to change the font.

If you use the Font command when no text is selected then you change the default font

and colour for that note.




3.7 Printing Notes

You can print a note by selecting the Print command from the right-click menu. You can
also print a note or notes from the main window.




3.8 Saving Data from Notes

If you have data in a note then you can cut and paste it into other applications, but it can
sometimes be useful to save the note data as a file. To do this simply select the Save as
command from the right-click menu which displays the Save Note As dialog box. You can
save the note data as rich text format, which preserves the formatting, or as simple text.




3.9 Moving Notes Between Folders

To move notes between folders you have to copy or cut the note from the current folder,
change folders and then paste the note into the new folder. You can copy or cut notes
either by selecting the Copy note or Cut note command from the note right-click menu , or
by selecting the note titles in the main window and choosing Cut note from the Edit menu.
To paste the note back into a folder move to the main window, change to the folder you
want the note in and then choose Paste note from the Edit menu.




3.10 Editting Notes

To edit a note either select the Edit title command from the right-click menu or double click
on the note title bar. You can also edit notes from the main window.
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In the dialog box you can type a title for the note, click the alarm button to set or change the
note alarm, and check one of the radio buttons to change the size and border of the note.

You can also set the note to be always on top.

You can import a file into the note by typing the file name into the import box. If you cannot
remember the file name you can click the Browse button to search for it. If you do import a
file then any text currently in the note will be overwritten by the new file and lost.



3.11 Changing Note Colours

You can change a note background colour by choosing the Note colour command from the
right-click menu. You can also change the default colour from the main window.
This will only change the background colour. If you want to change the text colour then

use the Font command from the right-click menu.




3.12 Deleting Notes

You can delete a note by selecting the Delete noe command from the right-click menu.
The deletion is permanent, and deleted notes cannot be recovered except with

considerable effort.

You can also delete notes from the main window.




3.13 Hiding and Displaying Notes

Notes are either visible, which means they are somewhere on the desktop, or they can be
hidden, which means they are invisible. For an application like a diary most notes would
normally be hidden, and only the ones for today would be visible. You can hide a note by
clicking on its minimise button or selecting Hide from the right-click menu, or you can get
the same effect by double left-clicking the system menu, or by choosing the Minimise or
Close commands from the system menu.

Hidden notes can be redisplayed from the main window or from the Diary and Calendar.




3.14 Saving changes to the note text

When you change the text in a note the note title will change to indicate that the contents
are unsaved. At any time you can select Save changes from the right-click menu or the
shortcut key control-S to save the changes. The changes are saved automatically when
the note is hidden or when NoteZ exits so you wont lose any work even if you forget to
save the changes.




3.15 Cancelling changes to the note text

| found while developing NoteZ that sometimes when a note alarm went off the note would
pop up in front of the word processor | was typing into, and the next few words would go
into the note before | could react. To undo unwelcome overwriting of the note select the
Cancel changes command from the right-click menu.

This is also useful if you have been editting a note and decided to abandon the changes
you have made. For local undo you can also use the standard Windows shortcut key alt-
backspace.

Note that the Cancel changes only applies to note text and will not undo changes to the
alarm or note title.




3.16 Always on top notes

It can sometimes be useful to have a note which always remains on top of other windows
even when it doesnt have the focus. To do this either select Edit title from the right-click
menu or double-click the note title bar to display the Edit Note dialog box, and check the
Always on top box. To stop the note from remaining on top simply repeat the process and

uncheck the box.




3.17 Cut, Copy and Paste

The cut, copy and paste commands on the the right-click menu simply perform cut, copy
and paste operations on the note text. You can also use the shortcut keys control X, C and
V, or for traditionalists control-Insert, shift-Insert and shift-Delete.




4. The Diary Window

= MoteZ 19th June 94 *

Sunday 19th June 94 +
Monday 20th June 34
Tuesday 21zt June 94
2 Sumrmer Solstice
Starting at 0000
Wednezday Z2Z2nd June 94 :I
Thursday 23rd June 94

Frnday 24th June 94

Saturday 25th June 94

L]

The diary allows you to quickly review your notes. It shows up to seven days with the titles
and timings of any notes on those days. If there is more than one note on a day then the
notes are sorted in chronological order. You can scroll through the diary by using the scroll
bar, or if the calendar window is visible you can jump to a particular day by right clicking on
that day in the Calendar.

Displaying Notes from the Diary
Creating Notes from the Diary
Changing the Diary Date
Printing the Diary

The Diary Font

Hiding the Diary




4.1 Displaying Notes from the Diary

The Diary can be used to display notes which are hidden. If you see a note in the diary
which you want to display then double left-click over the note title to display it.

Double left clicking will display a note in the Main and Calendar windows as well.



4.2 Creating Notes from the Diary

The Diary can be used to create new notes. This can be done either by double right-
clicking on the Diary or by drag-dropping a file on the Diary from the File Manager.

Double right-clicking

To create a new empty note on a day in the Diary just double right-click over that day, and
this will bring up the Edit Note dialog box. The note time will be set to the day you clicked
over, and the note alarm will be on. You can use the Edit Note dialog box to set the note
title, alarm and size.

Drag-Dropping

If you drag a file from File Manager (or another application that allows drag-dropping) onto
the Diary then a note will automatically be created containing the dropped file. The note
time will be set to the day the file was dropped on, and the note alarm will be on. The
note will be created with the current default size.



4.3 Changing the Diary Date

When NoteZ is started the Diary shows todays date (that is the PCs date) at the top, and
below this the next seven days. To change one day at a time left-click the arrows at the
top or bottom of the scroll bar. To change one week at a time left-click just above or just
below the scroll bar thumb. Dragging the scroll bar thumb does not have any effect.

If you want to jump to a date the easiest way is to right-click once on that day in the
Calendar, and the Diary will immediately change to show that day.



4.4 Printing the Diary
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The Diary can be printed by left-clicking on the system menu at the extreme top left of the
Diary window, and then choosing the Print command. A dialog box will be displayed to
allow you to specify what period to print. Note that the printout of the Diary always starts
at the first date shown in the Diary window.




4.5 The Diary Font

By default the Diary will use the smallest size of the MS Sans Serif font. You can change
the font used in the Diary by choosing the Change font/Diary font from the Select menu in

the Main window.

The Diary font is remembered on a folder by folder basis.



4.6 Hiding the Diary

If you do not want to display the Diary then left-click the minimise button at the extreme
top right of the Diary window, and the Diary will disappear. If you want to display the
Diary again then go to the Main window and choose the Show diary command from the
View menu.

NoteZ remembers whether the Diary is visible or not on a folder by folder basis. For
example, for a folder you use as a telephone list the Diary can be hidden and will stay
hidden. For a folder used as a diary the Diary can be left visible. When you switch
between the folders the Diary will be hidden and redisplayed as required.



5. The Calendar Window
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The Calendar shows the whole of the current year. Todays date is marked with a green dot,
and any days that have notes are marked in red. The Calendar is too small to list the titles
of notes, but you can find out what notes lie under a red marker by left double-clicking to
display them or by using the Diary.

Displaying Notes from the Calendar
Creating Notes from the Calendar
Changing the Calendar Year

Hiding the Calendar




5.1 Displaying Notes from the Calendar

The Calendar can be used to display notes which are hidden. For example, suppose 25th
December has a red mark to indicate there is a note there, then double left-click on 25/12
in the Calendar and all notes on that day will be displayed.

Double left clicking will display a note in the Main and Diary windows as well.




5.2 Creating Notes from the Calendar

The Calendar can be used to create new notes. This can be done either by double right-
clicking on the day you want the note or by drag-dropping a file on the Calendar from the
File Manager.

Double right-clicking

To create a new empty note on a day in the Calendar just double right-click over that day,
and this will bring up the Edit Note dialog box. = The note time will be set to the day you
clicked over, and the note alarm will be on. You can use the Edit Note dialog box to set the
note title, alarm and size.

Drag-Dropping

If you drag a file from File Manager (or another application that allows drag-dropping) onto
the Calendar then a note will automatically be created containing the dropped file. The
note time will be set to the day the file was dropped on, and the note alarm will be on.
The note will be created with the current default size.



5.3 Changing the Calendar Year

At the right end of the Calendar are three buttons labelled "Next", "Goto" and "Last". Left-
clicking on the Next and Last buttons moves to next and last year respectively.

MoteZ Calendar
Change calendar to yearlEE
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Clicking the Goto button brings up a dialog box which allows you to choose any year. You
can also left-click the system menu at the extreme top left of the Calendar window and
choose the Change year command.




5.4 Hiding the Calendar

If you do not want to display the Calendar then left-click the minimise button at the
extreme top right of the Calendar window, and the Calendar will disappear. If you want to
display the Calendar again then go to the Main window and choose the Show calendar
command from the View menu.

NoteZ remembers whether the Diary is visible or not on a folder by folder basis. For
example, for a folder you use as a telephone list the Diary can be hidden and will stay
hidden. For a folder used as a diary the Diary can be left visible. When you switch
between the folders the Diary will be hidden and redisplayed as required.



6. How NoteZ Stores Data

You need to know a little bit about how NoteZ stores its data so you can back up the data to
protect against hardware failures or virus attacks. On the other hand, the exact details of
how data is stored should not be important unless there is some catastrophe and your data
is mangled. The next section gives a basic description of the data format, and the
subsequent sections give the sort of detailed information you might need as a last resort.

Format of NoteZ Data

The NoteZ Header File Format
Moving NoteZ Folders

If Disaster Stikes




6.1 Format of Stored Data

NoteZ stores its data in folders. Each folder is held in a separate directory, and within this
directory is a header file called header.txt, and several note files called noteXXXX.txt.
These files hold the note contents in rich text format.

To back up data you simply need to archive all the directories that contain NoteZ data.
This job is made easier because all the directories are usually kept together.

In the ini file notez30.ini in the windows directory there is an entry

FolderPath=<a directory>
that tells NoteZ where the directories that contain its folders are kept. You can change this
entry by using the Change folder command from the Select menu in the Main window.




6.2 The Header File Format

The NoteZ header files start with the line
NoteZ30

NoteZ uses this to check that the directory does contain a NoteZ folder. Following this
there are 10 lines for each note as illustrated below

Note (each new note starts with the word Note)

Meeting on Thursday (the title)

note0001.txt (the note contents file)

0,0,4,192,192 (the note position, size id, width and height)
1,1 (the visible and alarm on flags)

0,0,0 (the note text colour RGB format)

ff,ff,0 (the note background colour RGB format)
93,8,23,9,30,0 (the note date ie 9:30:00 am 23/8/93)
15,0,-2 (the warning time)

-1,-1,-3 (the duration time)

-1,-1,0 (the repeat interval)

The size id is 0 for default size, 1 for small, 2 for medium, 3 for large and 4 for sizeable.
This note is sizeable.

The format for the last three entries is the number of intervals first then an interval type
which is O for a minute, 1 for an hour, 2 for a day, 3 for a month and 4 for a year. The third
number is an interval type flag, 0 means repeat, -2 means warning and -3 means duration.
-1 means the value is unset.



6.3 Moving NoteZ Folders

NoteZ keeps its data organised into folders, and each folder is kept in a separate directory.
For example, the two example folders are kept in the directories diary and recipes. Ifin
the course of reorganising your files you wish to move these directories you can move
them with File Manager like any other directory, but you must inform NoteZ where you
have moved them to. To do this use the Change folder command from the Select menu in
the Main window.

It is a very bad idea to have NoteZ running when you pull its directories out from under its
feet. This stands an excellent chance of corrupting your data. You should make sure
NoteZ is closed before moving any of its files around.



6.4 Recovering from Disaster

Page 1 in this section describes the format that NoteZ uses to store data, and in principle
you can use this information to rebuild a corrupted folder from scratch. In practise there
will be few reasons to want to do this, the most common one being that you accidently
delete a note or notes and do not have a recent backup.

When you delete a note this does two things. It deletes the noteXXXX.txt file that holds
the note contents and it modifies header.txt to remove the reference to the note. If
something awful happens:

i) quit NoteZ immediately before any more damage is done.

i) use a suitable undelete program to restore any noteXXXX.txt files that were
accidently deleted.

iii) if you were quick you will find header.bak contains the previous version of header.txt,
S0 you may be able to simply copy header.bak to header.txt to recreate the folder.

iv)  if header.bak is no good then you can copy the undeleted noteXXXX.txt files
somewhere else, restart notes and then drag-drop the files onto NoteZ to create new
notes. This will lose your titles alarms etc, but there really is no way to recover
these.



Registration

NoteZ is shareware, if you like it enough to use it please do the decent thing and register it.

You can register on Compuserve by typing GO SWREG and choosing reference number
3053, or you can send 10 pounds sterling or 15 US dollars to me. | cannot take credit
cards, but cheques in sterling or US dollars or indeed cash are welcome and should be sent
to:

John Rennie.

18 Shaftesbury Avenue,
Vicars Cross,

Chester. CH3 5LQ
United Kingdom

jrennie@cix.compulink.co.uk
10027.2376@compuserve.com






